aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..33fc587
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+import os
+from setuptools import setup
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+setup(
+ name = 'pyfarbpracht',
+ version = '0.1',
+ author = 'Oliver Meckmann',
+ author_email = 'omeckman@omeckman.net',
+ description = ('ANSI and BBCode color support'),
+ license = 'BSD 3-Clause',
+ keywords = 'ansi bbcode cli',
+ url = """https://git.omeckman.net/pyfarbpracht.git/""",
+ packages=['pyfarbpracht'],
+ long_description=read('README.md'),
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Topic :: Utilities",
+ "License :: BSD 3-Clause License",
+ ],
+)
in each repos: see "about"-tab (if existing) for more details / README.
mailto contact at omeckman dot net
all timestamps in UTC (German winter time: UTC+01:00, summer time: UTC+02:00)
dark theme is a modded version of: https://gist.github.com/Yoplitein/f4b671a2ec70c9e743fa